Issue creating new dedicated servers in Google Cloud
Incident Report for CloudAMQP
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 17:33 UTC
Identified
Creating new servers in Google Cloud is currently not working. This issue does not affect current running servers. We're working with Google Cloud to resolve the issue.

Servers created now will eventually be created, when this issue is resolved.

This issue only affects Google Cloud.
Posted Oct 31, 2019 - 13:04 UTC
This incident affected: Dedicated servers.