Backend slow/unresponsible

Incident Report for CloudAMQP

Resolved

We had an abnormal increase in traffic causing timeouts and slow responses for customer.cloudamqp.com, we increased capacity and are back to normal. This did not affect any running clusters, just provisioning and configuration updates.
Posted Apr 28, 2026 - 11:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2026 - 10:53 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 28, 2026 - 10:49 UTC

Investigating

We are currently experiencing issues with our backend services handling account and server creation.
This does not affect any running customer servers but might delay provisioning new servers.
Posted Apr 28, 2026 - 10:27 UTC
This incident affected: Backend.