Servers Unreacheable - Azure West US

Incident Report for CloudAMQP

Monitoring

Microsoft Azure confirmed they were having network issues on West US region. For now, most of the servers are operational. We'll keep monitoring for the following hours.
Posted Jul 23, 2026 - 19:50 UTC

Investigating

We've received various alert notifying us about couple of servers deployed on Azure West US not being reachable. Apparently this seems to be related specific to this region impacting 25% of the servers.
Posted Jul 23, 2026 - 15:33 UTC
This incident affects: Dedicated servers and Microsoft Azure.