Connecting issues in Azure West Europe

Incident Report for CloudAMQP

Resolved

This incident has been resolved.
Posted May 04, 2026 - 01:44 UTC

Identified

Servers in Azure West Europe can experience connection issues due to underlying issues at provider.

Latest update from Azure

"Current Status: We continue to investigate an availability issue caused by a subset of unhealthy backend storage infrastructure supporting Azure Virtual Machines and Azure Direct Drive in West Europe."
Posted May 03, 2026 - 19:14 UTC

Investigating

We are currently investigating this issue.
Posted May 03, 2026 - 19:11 UTC
This incident affected: Microsoft Azure.