AWS region me-central-1 outage

Incident Report for CloudAMQP

Update

We are continuing to monitor. The outage is in regards to the AZ mec1-az2
Posted Mar 02, 2026 - 01:46 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 01, 2026 - 13:23 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 01, 2026 - 13:22 UTC

Monitoring

AWS has an ongoing issue with multiple services in region me-central-1.
Posted Mar 01, 2026 - 13:20 UTC
This incident affects: Dedicated servers.