Monitoring Systems — False Alarms

Incident Report for CloudAMQP

Resolved

This incident has been resolved.
Posted May 31, 2026 - 11:29 UTC

Monitoring

Between 17:30 and 20:00 UTC on 2026-05-30, our server monitoring system generated a large number of false "server_unreachable" alerts. Clusters were operational and healthy throughout this period — no customer data or message delivery was affected.

The alerts were caused by a rolling restart of our monitoring service, during which individual monitoring workers went offline mid-cycle and lost state. This caused the workers to report connection timeouts for servers they could no longer reach — even though those servers were fully healthy.

We apologize for any concern this may have caused.
Posted May 30, 2026 - 22:25 UTC