We have observed that impacted clusters has restored services, and are working to ensure everything is back to normal.
Posted Nov 06, 2025 - 01:50 UTC
Monitoring
Update from Azure - Current Status: We detected this issue via our automated service monitoring, which identified a spike in hardware temperatures and service incidents affecting multiple clusters. We are actively investigating the cause and working with on-site technicians to restore normal cooling and service operations. The next update will be provided within 60 minutes, or as events warrant.
AZ 1 and 2are impacted.
Posted Nov 05, 2025 - 19:21 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 05, 2025 - 18:50 UTC
Identified
Access to Azure west Europe Availability zone 2 has been interrupted. Monitoring Azure and their report on the issue.
Posted Nov 05, 2025 - 17:47 UTC
This incident affected: Dedicated servers and Microsoft Azure.