Email Delays

Incident Report for CloudAMQP

Resolved

This incident has been resolved by third party.
Posted Dec 11, 2025 - 13:12 UTC

Investigating

emails and replies are delayed due to Helscout connection issues https://status.helpscout.com/incidents/kmd031b5fm16,
Posted Dec 11, 2025 - 12:16 UTC
This incident affected: Help Scout Email Processing.