Email delays

Incident Report for CloudAMQP

Resolved

This incident has been resolved
Posted Sep 12, 2024 - 07:34 UTC

Update

Emails seem to be operational again.
Posted Sep 12, 2024 - 06:55 UTC

Investigating

Our email provider has reported degraded performance and slowness in email processing. There may be delays in responses.
Posted Sep 12, 2024 - 06:42 UTC
This incident affected: Help Scout Email Processing.